Tags

, , ,

While installing the mysql gem in Ubuntu 9.10, I encountered this error:

Error:

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options.

After a bit of searching in the forums, got a solution that worked fine without a need for any configuration options:

Fix:

Execute sudo apt-get install libmysqlclient15-dev to install the package “libmysqlclient15-dev“.

Advertisements